EIGRP Frame-Relay HUB and Spoke using Cisco routing devices 1of 2 Method

Broadcast, used for mapping DLCIs, is essential when implementing multipoint frame relay hub and spoke networks. It must be configured with frame relay mapping for its multicast packets, including routing protocol update massages such as Cisco EIGRP, to be sent through the frame relay switch or cloud.

In our simulated procedure, full connection between all three routers in the Cisco packet tracer was not attained. However, it will function in a physical Cisco router. Nevertheless, when using it, consider compatibility issues and the Cisco IOS version.

Serial Interface Port and Frame Relay

NY-R

  • Router>enRouter#conf t

    Router(config)#hostname NY-R

    NY-R(config)#interface serial 0/0/0

    NY-R(config-if)#ip address 10.11.0.2 255.255.255.248

    NY-R(config-if)#encapsulation frame-relay ietf

    NY-R(config-if)#no frame-relay inverse-arp

    NY-R(config-if)#frame-relay map ip 10.11.0.1 200 broadcast

    NY-R(config-if)#frame-relay map ip 10.11.0.3 200

    NY-R(config-if)#no shutdown

    NY-R(config-if)#end

    NY-R#copy run start

HQ-R

  • Router>enRouter#conf t

    Router(config)#hostname HQ-R

    HQ-R(config)#interface serial 0/0/0

    HQ-R(config-if)#ip address 10.11.0.1 255.255.255.248

    HQ-R(config-if)#encapsulation frame-relay ietf

    HQ-R(config-if)#no frame-relay inverse-arp

    HQ-R(config-if)#frame-relay map ip 10.11.0.2 100 broadcast

    HQ-R(config-if)#frame-relay map ip 10.11.0.3 101 broadcast

    HQ-R(config-if)#no shutdown

    HQ-R(config-if)#end

    HQ-R#copy run start

LN-R

  • Router>enRouter#conf t

    Router(config)#hostname LN-R

    LN-R(config)#interface serial 0/0/0

    LN-R(config-if)#ip address 10.11.0.3 255.255.255.248

    LN-R(config-if)#encapsulation frame-relay ietf

    LN-R(config-if)#no frame-relay inverse-arp

    LN-R(config-if)#frame-relay map ip 10.11.0.1 300 broadcast

    LN-R(config-if)#frame-relay map ip 10.11.0.2 300

    LN-R(config-if)#no shutdown

    LN-R(config-if)#end

    LN-R#copy run start

Below are examples of errors that may occur if broadcast is not used at the end DLCI mapping. Should they occur in Cisco packet tracer, they may not necessarily do so in a physical router.

  • LN-R#conf tLN-R(config)#interface Serial0/0/0

    LN-R(config-if)#frame-relay map ip 10.11.0.2 300

%DUAL-5-NBRCHANGE: IP-EIGRP 2: Neighbor 10.11.0.2 (Serial0/0/0) is down: holding time expired

  • LN-R(config-if)#exitLN-R(config)#exit

    LN-R#copy run start

Router Serial Interface Port Bandwidth

HQ-R

  • HQ-R>enableHQ-R#configure terminal

    HQ-R(config)#interface serial 0/0/0

    HQ-R(config-if)#bandwidth 128

    HQ-R(config-if)#ip bandwidth-percent eigrp 1 50

    HQ-R(config-if)#end

    HQ-R#copy run start

LN-R

  • LN-R>enLN-R#conf t

    LN-R(config)#interface serial 0/0/0

    LN-R(config-if)#bandwidth 64

    LN-R(config)#end

    LN-R#copy run start

NY-R

  • NY-R#enableNY-R#configure terminal

    NY-R(config)#interface serial 0/0/0

    NY-R(config-if)#bandwidth 64

    NY-R(config-if)#end

    NY-R#copy run start

FastEthernet Interface port implementation

NY-R

  • NY-R>enNY-R#conf t

    NY-R(config)#interface fa0/0

    NY-R(config-if)#ip address 172.20.4.65 255.255.255.248

    NY-R(config-if)#no shutdown

    NY-R(config-if)#interface fa0/1

    NY-R(config-if)#ip address 172.20.4.89 255.255.255.248

    NY-R(config-if)#no shutdown

    NY-R(config-if)#end

    NY-R#copy run start

LN-R

  • LN-R#conf tLN-R(config)#interface fa0/0

    LN-R(config-if)#ip address 172.20.5.97 255.255.255.248

    LN-R(config-if)#no shutdown

    LN-R(config-if)#interface fa0/1

    LN-R(config-if)#ip address 172.20.5.65 255.255.255.248

    LN-R(config-if)#no shutdown

    LN-R(config-if)#end

    LN-R#copy run start

    LN-R#

How to configure EIGRP and autonomous system number (ASN) to connect the three routers together.

EIGRP and Autonomous system number (2)

HQ-R

  • HQ-R>enableHQ-R#conf t

    HQ-R(config)#router eigrp 2

    HQ-R(config-router)#network 10.11.0.0

    HQ-R(config-router)#no auto-summary

    HQ-R(config-router)#end

    HQ-R#copy run start

LN-R

  • LN-R#conf tLN-R(config)#router eigrp 2

    LN-R(config-router)#network 10.11.0.0

    LN-R(config-router)#network 172.20.5.0

    LN-R(config-router)#no auto-summary

    LN-R(config-router)#end

    LN-R#copy run start

NY-R Router

  • NY-R>enNY-R#conf t

    NY-R(config)#router eigrp 2

    NY-R(config-router)#network 10.11.0.0

    NY-R(config-router)#network 172.20.4.0

    NY-R(config-router)#no auto-summary

    NY-R(config-router)#end

    NY-R#copy run start

To configure a summary route manually in EIGRP

Autonomous system number 2 specifies that the manually summarized route be sent out to nieghbors (with 2). This enables administrators to control it and saves time in reducing the various possible routes on the table to one direct path.

Summary route, manual

NY-R

  • NY-R#conf tNY-R(config)#interface serial 0/0/0

    NY-R(config-if)#ip summary-address eigrp 2 172.20.0.0 255.255.240.0

    NY-R(config-if)#end

    NY-R#copy run start

LN-R

  • LN-R>enLN-R#conf t

    LN-R(config)#interface serial 0/0/0

    LN-R(config-if)#ip summary-address eigrp 2 172.20.0.0 255.255.240.0

    LN-R(config-if)#end

    LN-R#copy run start

no ip split-horizon eigrp allows advertised routes to reach all the network. Configure it in EIGRP routing domain with autonomous system number 2.

  • HQ-R>enHQ-R#conf t

    HQ-R(config)#interface serial 0/0/0

    HQ-R(config-if)#no ip split-horizon eigrp 2

    HQ-R(config-if)#end

    HQ-R#copy run start

Configure non-broadcast EIGRP mode on the Routers to enable EIGRP to send uncast packets out of the interface automatically. Verify it with show ip eigrp nieghbors

  • HQ-R>enHQ-R#conf t

    HQ-R(config)#router eigrp 2

    HQ-R(config-router)#neighbor 10.11.0.2 serial s0/0/0

    HQ-R(config-router)#neighbor 10.11.0.3 serial s0/0/0

    HQ-R(config-if)#end

    HQ-R#copy run start

  • LN-R>enLN-R#conf t

    LN-R(config)#router eigrp 2

    LN-R(config-router)#neighbor 10.11.0.1 serial s0/0/0

    LN-R(config-if)#end

    LN-R#copy run start

  • NY-R>enNY-R#conf t

    NY-R(config)#router eigrp 2

    NY-R(config-router)#neighbor 10.11.0.1 serial s0/0/0

    NY-R(config-if)#end

    NY-R#copy run start

A non physical network can be simulated by implementing a loopback interface with ip address, which is also useful for investigation and test purposes

Loopback interface configuration

NY-R

  • NY-R#conf t.NY-R(config)#interface loopback1

    NY-R(config-if)#ip address 172.20.7.65 255.255.255.248

    NY-R(config-if)#exit

    NY-R(config)#interface loopback10

    NY-R(config-if)#ip address 172.20.6.89 255.255.255.248

    NY-R(config-if)#interface loopback11

    NY-R(config-if)#ip address 172.20.10.89 255.255.255.248

    NY-R(config-if)#end

    NY-R#copy run start

Verify the routing table and EIGRP function with:

  • NY-R#show ip routeNY-R#show ip eigrp topology

Check connection with ping on CMD in Microsoft Windows or Linux terminal.

Additional info. for frame relay

Frame Relay is a layer 2 WAN protocol and operates at the data layer of the OSI. One of its drawbacks is not to be able to ping its own interface to test connectivity. Although to do so, puts more burden on resources. Implementation:

  • LN-R>enLN-R#conf t

    LN-R(config)#interface s0/0/0

    LN-R(config-if)#frame-relay map ip 10.11.0.1 101

Errors indicate that IP mapping address is present in the same subnet network. Some examples of errors:

%Address already in map

  • LN-R(config-if)#frame-relay map ip 10.11.0.1 100

%Address already in map

Chapter 3 Exam Question Answers 2013 – Introduction to Networks (Version 5.0)

Chapter 3 Exam Question Answers 2013 – Introduction to Networks (Version 5.0)

[ads2]

1. A computer in a given network is communicating with a specific group of computers. What type of communication is this?

Multicast

2. What method can be used by two computers to ensure that packets are not dropped because too much data is being sent too quickly?

flow control

3. Which protocol is responsible for controlling the size and rate of the HTTP messages exchanged between server and client?

TCP

4. A user is viewing an HTML document located on a web server. What protocol segments the messages and manages the segments in the individual conversation between the web server and the web client?

TCP

5. A web client is sending a request for a webpage to a web server. From the perspective of the client, what is the correct order of the protocol stack that is used to prepare the request for transmission?

HTTP, TCP, IP, Ethernet

6. What are proprietary protocols?

protocols developed by organizations who have control over their definition and operation

7. Which IEEE standard enables a wireless NIC to connect to a wireless AP that is made by a different manufacturer?

802.11

8. What is an advantage of network devices using open standard protocols?

A client host and a server running different operating systems can successfully exchange data.

9. What is a function of Layer 4 of the OSI model?

to describe the ordered and reliable delivery of data between source and destination

10. Which statement is true about the TCP/IP and OSI models?

The TCP/IP transport layer and OSI Layer 4 provide similar services and functions.

11. What is a benefit of using a layered model for network communications?

fostering competition among device and software vendors by enforcing the compatibility of their products

12. What is the general term that is used to describe a piece of data at any layer of a networking model?

[ads2]

protocol data unit

13. Which PDU format is used when bits are received from the network medium by the NIC of a host?

Frame

14. At which layer of the OSI model would a logical address be encapsulated?

Network layer

15. Which statement accurately describes a TCP/IP encapsulation process when a PC is sending data to the network?

Segments are sent from the transport layer to the internet layer.

16. What statement describes the function of the Address Resolution Protocol?

ARP is used to discover the MAC address of any host on the local network.

17. Which address provides a unique host address for data communications at the internet layer?

logical address

18. Which address does a NIC use when deciding whether to accept a frame?

destination MAC address

19. A user sends an HTTP request to a web server on a remote network. During encapsulation for this request, what information is added to the address field of a frame to indicate the destination?

the MAC address of the default gateway

20. If the default gateway is configured incorrectly on the host, what is the impact on communications?

The host can communicate with other hosts on the local network, but is unable to communicate with hosts on remote networks.

21. IEEE -> is a professional organization for those in the electrical engineering and electronics fields. It creates and maintains standards affecting a wide range of industries including telecommunications, and networking.

EIA -> is an international standards and trade organization for electronics organizations. It is best known for its standards related to electrical wiring, connectors, and the 19-inch racks used to mount networking equipment.

22. Open the PT Activity. Perform the tasks in the activity instructions and then answer the question.

Based on the configured network, what IP address would PC1 and PC2 use as their default gateway?

192.168.1.1

Chapter 1 Routing Protocols Exam Question Answers 2013 v.5

Chapter 1 Routing Protocols Exam Question Answers 2013 v.5

Chapter 1 Routing Protocols Exam Question Answers 2013 v.5

Chapter 1 Exam Question Answers 2013 – Routing Protocols (Version 5.0) – RP

1. A computer in a given network is communicating with a specific group of computers. What type of communication is this?

Multicast

2. What method can be used by two computers to ensure that packets are not dropped because too much data is being sent too quickly?

flow control

3. Which protocol is responsible for controlling the size and rate of the HTTP messages exchanged between server and client?

TCP

4. A user is viewing an HTML document located on a web server. What protocol segments the messages and manages the segments in the individual conversation between the web server and the web client?

TCP

5. A web client is sending a request for a webpage to a web server. From the perspective of the client, what is the correct order of the protocol stack that is used to prepare the request for transmission?

HTTP, TCP, IP, Ethernet

6. What are proprietary protocols?

protocols developed by organizations who have control over their definition and operation

7. Which IEEE standard enables a wireless NIC to connect to a wireless AP that is made by a different manufacturer?

802.11

8. What is an advantage of network devices using open standard protocols?

A client host and a server running different operating systems can successfully exchange data.

9. What is a function of Layer 4 of the OSI model?

to describe the ordered and reliable delivery of data between source and destination

10. Which statement is true about the TCP/IP and OSI models?

The TCP/IP transport layer and OSI Layer 4 provide similar services and functions.

11. What is a benefit of using a layered model for network communications?

fostering competition among device and software vendors by enforcing the compatibility of their products

12. What is the general term that is used to describe a piece of data at any layer of a networking model?

protocol data unit

13. Which PDU format is used when bits are received from the network medium by the NIC of a host?

Frame

14. At which layer of the OSI model would a logical address be encapsulated?

Network layer

15. Which statement accurately describes a TCP/IP encapsulation process when a PC is sending data to the network?

Segments are sent from the transport layer to the internet layer.

16. What statement describes the function of the Address Resolution Protocol?

ARP is used to discover the MAC address of any host on the local network.

17. Which address provides a unique host address for data communications at the internet layer?

logical address

18. Which address does a NIC use when deciding whether to accept a frame?

destination MAC address

19. A user sends an HTTP request to a web server on a remote network. During encapsulation for this request, what information is added to the address field of a frame to indicate the destination?

the MAC address of the default gateway

20. If the default gateway is configured incorrectly on the host, what is the impact on communications?

The host can communicate with other hosts on the local network, but is unable to communicate with hosts on remote networks.

21.

IEEE -> is a professional organization for those in the electrical engineering and electronics fields. It creates and maintains standards affecting a wide range of industries including telecommunications, and networking.

EIA -> is an international standards and trade organization for electronics organizations. It is best known for its standards related to electrical wiring, connectors, and the 19-inch racks used to mount networking equipment.

Clipboard01

22. Open the PT Activity. Perform the tasks in the activity instructions and then answer the question.

Based on the configured network, what IP address would PC1 and PC2 use as their default gateway?

192.168.1.1

نبذة لدخول عالم ومجال سيسكو Cisco

السلام عليكم ورحمة الله و بركاته

الكثير منا لم يكن يعرف ماهي الشبكات ؟ اذا اول سؤال يجب ان نسأله لنفسنا ماهي الشبكات

قبل ذلك اريد ان اذكر بشئ بسيط :
اخي المبتدأ ارغب ان اشرح لك معنى تقنية المعلومات IT بصوره مختصره فالشبكات جزء منها

تقنيتة المعلومات تنقسم الى قسمين

الاول / SOFTWARE , C , C++ , JAVA etc………

الثاني :

Hardware , MCSE ,MCITP,CCNA,CCNP …..etc

بمعنى اخر او بتقسيم اخر

LAN : SYSTEM ADMINISTRATOR الشبكه المحليه
الشبكه الواسعه WAN : NETWORK/ SECURITY ADMINISTRATOR

اذا اردنا العمل مع الشبكه المحليه هذا يعني اننا سنحتاج للاتي

1-اكثر من كمبيوتر واحد
2- O/S نظام تشغيل و سوف اشرح انظمة التشغيل بصوره سريعه

مايكروسوفت انتج ما يسمى بي :

ا- نظام التشغيل الخاص بالمستخدم CLIENT

و هي من الاقدم الى الاحدث

WIN 3.11
WIN 95
WIN 98
WIN 2000 PRO
WIN XP SP1,SP2,SP3
WIN VISTA
WIN 7
ب-نظام التشغيل المتحكم بالمستخدم SERVERS

و هي من الاقدم الى الاحدث

WIN SERVER NT 4.0
WIN SERVER 2000 بإصدارات ثلاثه هي
interprise, web, data center
WIN SERVER 2003 OR MCSE
WIN SERVER 2008 OR MCITP

LINUX ,SUN ايضا لا ننسى انظمة التشغيل هذه و هي ذات حمايه عاليه جدا و اغلب شركات الاتصالات تعمل بهذه الانواع من انظمة التشغيل اذا كانت الشركه معنمده على اجهزه من شركة IBM و هي شركه مصنعه للسيرفرات و غيرها .

3- و نعود مرة اخرى و نذكر ثالث احتياجاتنا لعمل شبكه محليه NIC او ما يطلق عليه كرت الشبكه فمن غيره لايوجد شبكه و البورت الذي به او المدخل يسمى ETHERNET , FAST ETHERNET , GIGA ETHERNET

4-الكيبل CABLE و سأتحدث عنها في نقاط سريعه و التفصيل انت ستبحث عنه انا اعطيك الطريقه فقط كيف و بماذا تبدأ و لماذا ؟

النوع الاول: COXIAL
النوع الثاني : TWISTED و ينقسم الى نوعين و الفرق بينهما ان الاول صلب و ينكسر بسرعه لذلك غير مستخدم
لثاني مرن و يسهل التعامل معه

الاول STP shielded twisted pair و هذا هو النوع الصلب الغير مستخدم

الثاني UTP unshielded twisted pair و ههذا النوع المرن و يتكون من 8 اسلاك , و منها نوعان احدها للهاتف cat 1 RJ 11 2mbps
cat2 4mbps
cat3 10mbps
cat 4 16mbps
cat5 و هذا يستخدم للنت و يركب بكلبس يسمى RJ45 100MBPS
cat 6 1000 mbps

النوع الثالث / الفايبر اوبتيك يعني لازم تتعرف على جميع الكيبل

اريد من الجميع التركيز هنا
5- protocols و هذا ما سنحتاج الى معرفته لان الشبكه كلها تعمل ببرتكولات

6- الاجهزه الموصله other divices : switch , hub ,

يعني لازم تتعرف على كل انواع الاجهزه المستخدمه

بعد اعداد كل هذا سنصل سنكون قد انجزنا شبكه محليه و لكن ايضا هناك شئ صغير يجب ان نعرفه

اذا كانت الشبكه مرتبطه من غير متحكم تسمى WORKGROUP

اذا كانت مرتبطه بمتحكم اي سيرفير 2008 او 2003 او غيره تسمى دومين DOMAIN و هذا النوع تعمل به الشركات حتى تتحكم في مسار عمل الشركه و الموظفين و تسهيل نقل البيانات من مكان لاخر.

نأتي هنا و للاهم المهم و الذهب و الالماس عالم سيسكو :

بكل بساطه في الاعلى ذكرت ان الشركات تعمل بدومين هذا يعني ان الشركه اصبحت تتعامل بالكمبيوتر مربوطه ببعضها البعض اي هناك شبكه و في موقع محدد مثلا الرياض

قام صاحب الشركه بإنشاء فرع اخر في احدى المدن او الدول بالتأكيد سوف يقوم بتجهيز الفرع الجديد بكمبيوترات , او فالنقل سيقوم بعمل شبكه محليه للفرع لتسهيل العمل كما في الرياض

صاحب الشركه يريد ان يربط شبكة الفرع الجديد بالشركة الرئيسيه في الرياض ماذا سيحدث او ماذا سنفعل هنا ؟

سيأتي دور سيسكو اي اننا سنتعامل مع الراوترز و السويتش من الطبقه الثانيه و سوتيش من الطبقه الثالثه و هي تعمل عمل الراوتر ايضا حديثه جدا

فأجهزة سيسكو هي التي تعمل على ربط تلك المددينتين او الدولتين ببعضهما البعض و تسمى هذه الشبكه بالشبكه الواسعه WAN

سأكتفي بهذا الان وسأكمل بقية القصه و سأدلك اخي الى طريقك نحو كيفية دراسة و تطبيق الشبكه الواسعه و اعتقد ان المنتدى به الكثير من الدرر النفيسه مثل الاستاذ عدنان و غيره من الاخوان الافاضل و هذا الطرح هو طرح مبدأي لك اخي المبتدأ حتى تعرف ماهي الشبكه الواسعه و علاقتها بالشبكه المحليه و لكي تحدد ان كنت تريد ان تصبح mcitp or cisco certified

 

المصدر