EIGRP Frame-Relay HUB and Spoke using Cisco routing devices 1of 2 Method

Broadcast, used for mapping DLCIs, is essential when implementing multipoint frame relay hub and spoke networks. It must be configured with frame relay mapping for its multicast packets, including routing protocol update massages such as Cisco EIGRP, to be sent through the frame relay switch or cloud.

In our simulated procedure, full connection between all three routers in the Cisco packet tracer was not attained. However, it will function in a physical Cisco router. Nevertheless, when using it, consider compatibility issues and the Cisco IOS version.

Serial Interface Port and Frame Relay

NY-R

  • Router>enRouter#conf t

    Router(config)#hostname NY-R

    NY-R(config)#interface serial 0/0/0

    NY-R(config-if)#ip address 10.11.0.2 255.255.255.248

    NY-R(config-if)#encapsulation frame-relay ietf

    NY-R(config-if)#no frame-relay inverse-arp

    NY-R(config-if)#frame-relay map ip 10.11.0.1 200 broadcast

    NY-R(config-if)#frame-relay map ip 10.11.0.3 200

    NY-R(config-if)#no shutdown

    NY-R(config-if)#end

    NY-R#copy run start

HQ-R

  • Router>enRouter#conf t

    Router(config)#hostname HQ-R

    HQ-R(config)#interface serial 0/0/0

    HQ-R(config-if)#ip address 10.11.0.1 255.255.255.248

    HQ-R(config-if)#encapsulation frame-relay ietf

    HQ-R(config-if)#no frame-relay inverse-arp

    HQ-R(config-if)#frame-relay map ip 10.11.0.2 100 broadcast

    HQ-R(config-if)#frame-relay map ip 10.11.0.3 101 broadcast

    HQ-R(config-if)#no shutdown

    HQ-R(config-if)#end

    HQ-R#copy run start

LN-R

  • Router>enRouter#conf t

    Router(config)#hostname LN-R

    LN-R(config)#interface serial 0/0/0

    LN-R(config-if)#ip address 10.11.0.3 255.255.255.248

    LN-R(config-if)#encapsulation frame-relay ietf

    LN-R(config-if)#no frame-relay inverse-arp

    LN-R(config-if)#frame-relay map ip 10.11.0.1 300 broadcast

    LN-R(config-if)#frame-relay map ip 10.11.0.2 300

    LN-R(config-if)#no shutdown

    LN-R(config-if)#end

    LN-R#copy run start

Below are examples of errors that may occur if broadcast is not used at the end DLCI mapping. Should they occur in Cisco packet tracer, they may not necessarily do so in a physical router.

  • LN-R#conf tLN-R(config)#interface Serial0/0/0

    LN-R(config-if)#frame-relay map ip 10.11.0.2 300

%DUAL-5-NBRCHANGE: IP-EIGRP 2: Neighbor 10.11.0.2 (Serial0/0/0) is down: holding time expired

  • LN-R(config-if)#exitLN-R(config)#exit

    LN-R#copy run start

Router Serial Interface Port Bandwidth

HQ-R

  • HQ-R>enableHQ-R#configure terminal

    HQ-R(config)#interface serial 0/0/0

    HQ-R(config-if)#bandwidth 128

    HQ-R(config-if)#ip bandwidth-percent eigrp 1 50

    HQ-R(config-if)#end

    HQ-R#copy run start

LN-R

  • LN-R>enLN-R#conf t

    LN-R(config)#interface serial 0/0/0

    LN-R(config-if)#bandwidth 64

    LN-R(config)#end

    LN-R#copy run start

NY-R

  • NY-R#enableNY-R#configure terminal

    NY-R(config)#interface serial 0/0/0

    NY-R(config-if)#bandwidth 64

    NY-R(config-if)#end

    NY-R#copy run start

FastEthernet Interface port implementation

NY-R

  • NY-R>enNY-R#conf t

    NY-R(config)#interface fa0/0

    NY-R(config-if)#ip address 172.20.4.65 255.255.255.248

    NY-R(config-if)#no shutdown

    NY-R(config-if)#interface fa0/1

    NY-R(config-if)#ip address 172.20.4.89 255.255.255.248

    NY-R(config-if)#no shutdown

    NY-R(config-if)#end

    NY-R#copy run start

LN-R

  • LN-R#conf tLN-R(config)#interface fa0/0

    LN-R(config-if)#ip address 172.20.5.97 255.255.255.248

    LN-R(config-if)#no shutdown

    LN-R(config-if)#interface fa0/1

    LN-R(config-if)#ip address 172.20.5.65 255.255.255.248

    LN-R(config-if)#no shutdown

    LN-R(config-if)#end

    LN-R#copy run start

    LN-R#

How to configure EIGRP and autonomous system number (ASN) to connect the three routers together.

EIGRP and Autonomous system number (2)

HQ-R

  • HQ-R>enableHQ-R#conf t

    HQ-R(config)#router eigrp 2

    HQ-R(config-router)#network 10.11.0.0

    HQ-R(config-router)#no auto-summary

    HQ-R(config-router)#end

    HQ-R#copy run start

LN-R

  • LN-R#conf tLN-R(config)#router eigrp 2

    LN-R(config-router)#network 10.11.0.0

    LN-R(config-router)#network 172.20.5.0

    LN-R(config-router)#no auto-summary

    LN-R(config-router)#end

    LN-R#copy run start

NY-R Router

  • NY-R>enNY-R#conf t

    NY-R(config)#router eigrp 2

    NY-R(config-router)#network 10.11.0.0

    NY-R(config-router)#network 172.20.4.0

    NY-R(config-router)#no auto-summary

    NY-R(config-router)#end

    NY-R#copy run start

To configure a summary route manually in EIGRP

Autonomous system number 2 specifies that the manually summarized route be sent out to nieghbors (with 2). This enables administrators to control it and saves time in reducing the various possible routes on the table to one direct path.

Summary route, manual

NY-R

  • NY-R#conf tNY-R(config)#interface serial 0/0/0

    NY-R(config-if)#ip summary-address eigrp 2 172.20.0.0 255.255.240.0

    NY-R(config-if)#end

    NY-R#copy run start

LN-R

  • LN-R>enLN-R#conf t

    LN-R(config)#interface serial 0/0/0

    LN-R(config-if)#ip summary-address eigrp 2 172.20.0.0 255.255.240.0

    LN-R(config-if)#end

    LN-R#copy run start

no ip split-horizon eigrp allows advertised routes to reach all the network. Configure it in EIGRP routing domain with autonomous system number 2.

  • HQ-R>enHQ-R#conf t

    HQ-R(config)#interface serial 0/0/0

    HQ-R(config-if)#no ip split-horizon eigrp 2

    HQ-R(config-if)#end

    HQ-R#copy run start

Configure non-broadcast EIGRP mode on the Routers to enable EIGRP to send uncast packets out of the interface automatically. Verify it with show ip eigrp nieghbors

  • HQ-R>enHQ-R#conf t

    HQ-R(config)#router eigrp 2

    HQ-R(config-router)#neighbor 10.11.0.2 serial s0/0/0

    HQ-R(config-router)#neighbor 10.11.0.3 serial s0/0/0

    HQ-R(config-if)#end

    HQ-R#copy run start

  • LN-R>enLN-R#conf t

    LN-R(config)#router eigrp 2

    LN-R(config-router)#neighbor 10.11.0.1 serial s0/0/0

    LN-R(config-if)#end

    LN-R#copy run start

  • NY-R>enNY-R#conf t

    NY-R(config)#router eigrp 2

    NY-R(config-router)#neighbor 10.11.0.1 serial s0/0/0

    NY-R(config-if)#end

    NY-R#copy run start

A non physical network can be simulated by implementing a loopback interface with ip address, which is also useful for investigation and test purposes

Loopback interface configuration

NY-R

  • NY-R#conf t.NY-R(config)#interface loopback1

    NY-R(config-if)#ip address 172.20.7.65 255.255.255.248

    NY-R(config-if)#exit

    NY-R(config)#interface loopback10

    NY-R(config-if)#ip address 172.20.6.89 255.255.255.248

    NY-R(config-if)#interface loopback11

    NY-R(config-if)#ip address 172.20.10.89 255.255.255.248

    NY-R(config-if)#end

    NY-R#copy run start

Verify the routing table and EIGRP function with:

  • NY-R#show ip routeNY-R#show ip eigrp topology

Check connection with ping on CMD in Microsoft Windows or Linux terminal.

Additional info. for frame relay

Frame Relay is a layer 2 WAN protocol and operates at the data layer of the OSI. One of its drawbacks is not to be able to ping its own interface to test connectivity. Although to do so, puts more burden on resources. Implementation:

  • LN-R>enLN-R#conf t

    LN-R(config)#interface s0/0/0

    LN-R(config-if)#frame-relay map ip 10.11.0.1 101

Errors indicate that IP mapping address is present in the same subnet network. Some examples of errors:

%Address already in map

  • LN-R(config-if)#frame-relay map ip 10.11.0.1 100

%Address already in map

Networking Fundamentals Chapter 1

Networking Fundamentals Chapter 1

تعلم ccna الوحدة الأولى أساسيات الشبكات

Chapter 1

Networking Fundamentals

This chapter provides an overview of basic networking concepts, including network architecture, design, and project management.

Introduction to Networking Fundamentals

Networking History and Evolution

Overview

This manual focuses on server-based networks as the standard form of organizational networking. However, it should be noted that other types of networks are also used for  message exchange between users. The earliest form of electronic networking for the purpose  of message transfer was the local telephone exchange, which has evolved to become a carrier network providing transport services for both voice and data traffic on a global scale.  Data networks designed exclusively for computing environments followed the introduction of business computing in the 1950s. Prior to that time, computers were used mostly for research and national defense purposes.
Milestones in the history of data networking include:

  •  1960s—The first large-scale commercial computer network is created for an airline reservation application. Also, the Advanced Research Projects Agency Network  (ARPANET) successfully links computers developed by different manufacturers, forming what is later described as the origin of today’s Internet.
  •  1970s—A networking technology for minicomputers called Ethernet is developed.
  •  1980s—The increase in the number of stand-alone desktop microcomputers within  organizations encourages widespread adoption of local area networks (LANs).
  •  1990s—Web-based Internet resources are introduced on a global scale.
  •  2000s—Improved mobile/wireless devices and networks provide the means to connect to  an organizational network from nearly any location in the world. The advances in computing and communications technologies, and the decline in costs, have  made it possible to provide each user with multiple fixed or mobile processing devices (e.g., desktop, laptop, handheld, and home computers). Each of these devices is  independently capable of storing data and connecting to an organizational network, a home network, or the Internet. This is in contrast to earlier times, when all users had to share the processing and storage capabilities of a single centralized computer using desktop terminals. The evolution in computing can therefore be described as a migration from centralized to decentralized or distributed, with networks used to interconnect various types of computing and storage devices.

for more information and Download the PDF file please click Learn-CCNA-Chapter1-Networking-Fundamentals

this file taken from here