Configuring a Static Default Route

[notification type=”notification_info” ]The default route, also known as the gateway of last resort is used commonly to route traffic with no longer match towards the internet. This lab will discuss and demonstrate the configuration of a default route.[/notification]

Real World Application & Core Knowledge

As you may know, Cisco routers will match traffic to a destination based on the closest match found in the routing table. With that being said; if the router has two routes in the routing table, one for 10.88.21.0/28 and one for 10.88.21.0/24 and the router receives traffic destined towards the host 10.88.21.6 then the router will choose the 10.88.21.0/28 route as its a closer match

In the previous two labs you learned about static routing and floating static routes, you are going to continue to build upon that foundation with configuring a default static route; commonly referred to as a “default route”.

As a CCNA you must understand the concept of the default route on a Cisco router and how to configure them. It is common that a router will have a floating default route in production in case the dynamic routing protocol fails for whatever reason, the floating default route would be injected into the routing table and eliminate downtime if designed and implemented properly.

In a network there are commonly two ways to get to the internet from within the network. You can have a default route on your WAN edge router pointing towards the ISP so that if any traffic destined towards a network is not found in the routing table of your WAN edge router then it would be passed onto the ISP. The other possibility is to have a WAN edge router participate in BGP (Boarder Gateway Protocol) which is the protocol that the internet is built upon. Having a full internet routing table via BGP will give you the ability to have every route on the internet on a single router. However BGP does not fall within the scope of the CCNA level material so we’ll only be focusing on a default route.

If you are interested in how the internet works and curious about BGP then you’ll have to continue your studies on to the CCNP after you’ve completed the CCNA.

Configuring a Default Route is as simple as configuring a static route. A default route is represented by 0.0.0.0/0. If you take a second and analyze the network and subnet you’ll realize that any ip address can fall in this subnet from 0.0.0.0 to 255.255.255.255.

In this lab you will use the same topology that you’re worked with in the previous Lab 6-2 however the IP Addressing has been updated to reflect the lab number. You will be removing the static routes previously assigned to R3 and configuring a default route on R3 to point towards R2.

Familiarize yourself with the following new command(s);

Command Description
ip route 0.0.0.0 0.0.0.0 nh.nh.nh.nh # When specifying a static route to 0.0.0.0/0 you are effectively configuring a default route, a route that will catch all traffic if no other route exist for the traffic destination in the routing table.

Lab Prerequisites

[star_list]

  • If you are using GNS3 than load the Free CCNA Workbook GNS3 topology than start devices; R1, R2 and R3.
  • Establish a console session with devices R1, R2 and R3 than load the initial configurations provided below by copying the config from the textbox and pasting it into the respected routers console.[/star_list]
Test Text

 

[notification type=”notification_info” ]!##################################################
!# Free CCNA Workbook Lab 6-3 R1 Initial Config #
!##################################################
!
enable
configure terminal
!
hostname R1
!
interface Loopback0
description ### SIMULATED NETWORK ###
ip address 10.63.10.1 255.255.255.0
!
interface Serial0/0
description ### PHYSICAL FRAME RELAY INTERFACE ###
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.122 point-to-point
description ### FRAME RELAY LINK TO R2 ###
ip address 10.63.12.1 255.255.255.252
frame-relay interface-dlci 122
!
interface Serial0/0
no shut
!
interface Serial0/1
description ### PPP Link TO R2 ###
ip address 10.63.21.1 255.255.255.252
encapsulation ppp
serial restart-delay 0
no shut
!
exit
!
ip route 10.63.20.0 255.255.255.0 10.63.12.2
ip route 10.63.30.0 255.255.255.0 10.63.12.2
ip route 10.63.20.0 255.255.255.0 10.63.21.2 200
ip route 10.63.30.0 255.255.255.0 10.63.21.2 200
!
end

[/notification]

[notification type=”notification_info” ]!##################################################
!# Free CCNA Workbook Lab 6-3 R2 Initial Config #
!##################################################
!
enable
configure terminal
!
hostname R2
!
interface Loopback0
description ### SIMULATED NETWORK ###
ip address 10.63.20.1 255.255.255.0
!
interface Serial0/0
description ### PHYSICAL FRAME RELAY INTERFACE ###
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.221 point-to-point
description ### FRAME RELAY LINK TO R1 ###
ip address 10.63.12.2 255.255.255.252
frame-relay interface-dlci 221
!
interface Serial0/0.223 point-to-point
description ### FRAME RELAY LINK TO R3 ###
ip address 10.63.23.1 255.255.255.252
frame-relay interface-dlci 223
!
interface Serial0/0
no shut
exit
!
interface Serial0/1
description ### PPP LINK TO R1 ###
ip address 10.63.21.2 255.255.255.252
encapsulation ppp
serial restart-delay 0
no shut
!
ip route 10.63.10.0 255.255.255.0 10.63.12.1
ip route 10.63.30.0 255.255.255.0 10.63.23.2
ip route 10.63.10.0 255.255.255.0 10.63.21.1 200
!
end

[/notification]

 

[notification type=”notification_info” ]!##################################################
!# Free CCNA Workbook Lab 6-3 R3 Initial Config #
!##################################################
!
enable
configure terminal
!
hostname R3
!
interface Loopback0
description ### SIMULATED NETWORK ###
ip address 10.63.30.1 255.255.255.0
!
interface Serial0/0
description ### PHYSICAL FRAME RELAY INTERFACE ###
no ip address
encapsulation frame-relay
serial restart-delay 0
no frame-relay inverse-arp
!
interface Serial0/0.322 point-to-point
description ### FRAME RELAY LINK TO R2 ###
ip address 10.63.23.2 255.255.255.252
frame-relay interface-dlci 322
!
interface Serial0/0
no shut
exit
!
ip route 10.63.10.0 255.255.255.0 10.63.23.1
ip route 10.63.20.0 255.255.255.0 10.63.23.1
!
end[/notification]

Lab Objectives

  • Remove all currently configured static routes on R3 than configure a default route on R3 pointing towards R2’s Serial0/0.223 interface IP.
  • Verify that you have IP reachability from R3’s 10.63.30.0/24 network to R1’s 10.63.10.0/24 network.
  • Verify rather or not you can ping R1’s PPP backup interface IP address.

Lab Instruction

Objective 1. – Remove all currently configured static routes on R3 than configure a default route on R3 pointing towards R2’s Serial0/0.223 interface IP

[notification type=”notification_info” ]

R3#show run | include ip route
ip route 10.63.10.0 255.255.255.0 10.63.23.1
ip route 10.63.20.0 255.255.255.0 10.63.23.1
R3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#no ip route 10.63.10.0 255.255.255.0 10.63.23.1
R3(config)#no ip route 10.63.20.0 255.255.255.0 10.63.23.1
R3(config)#ip route 0.0.0.0 0.0.0.0 10.63.23.1
R3(config)#end
R3#

[/notification]

Objective 2. – Verify that you have IP reachability from R3’s 10.63.30.0/24 network to R1’s 10.63.10.0/24 network.

Previously the traffic would have taken the routes you just removed but now that the router has a default route it will take it as the route of last resort as shown below;

[notification type=”notification_info” ]

R3#ping 10.63.10.1 source lo0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.63.10.1, timeout is 2 seconds:
Packet sent with a source address of 10.63.30.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/82/168 ms
R3#

[/notification]

Objective 3. – Verify rather or not you can ping R1’s PPP backup interface IP address from 10.63.30.0/24.

Previously R3 had no route to get to the 10.63.21.0/30 network but now that a default route exist that points to R2 which has 10.63.21.0/3 directly connected and a route back to 10.63.30.0/24, IP reachability is feasible.

[notification type=”notification_info” ]

R3#ping 10.63.21.1 source lo0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.63.21.1, timeout is 2 seconds:
Packet sent with a source address of 10.63.30.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/81/116 ms
R3#

[/notification]